Most Amron website visitors using modern browsers and operating systems will not be impacted.  Only very old browsers and operating systems will be unable to make connections using the newer TLS protocol.  

 

We strongly encourage all users to upgrade their browsers immediately to avoid problems browsing amronintl.com and other web sites, as well as to ensure a fast and secure Internet experience.

 

Some old browsers do not properly support the secure HTTPS communication protocols TLS 1.1 or 1.2 by default. Older SSL 3.0 and TLS 1.0 protocols preferred by these old browsers will be disabled by many sites including amronintl.com before June 30th 2018 to improve security and privacy.

 

This change has been mandated by the PCI Security Standards Council, the organization that oversees security standards related to online payments.

https://blog.pcisecuritystandards.org/are-you-ready-for-30-june-2018-sayin-goodbye-to-ssl-early-tls

 

If you don’t know what browser version you are using visit: https://www.whatsmybrowser.org/


Browsers That Support TLS v.1.1+


Compatible Browsers Required

- Chrome® v.22+
- Firefox® version v.27+
- Internet Explorer® v.8-10 (if enabled)
- Internet Explorer v.11
- Safari® v.7+
- Edge®


Mobile Browsers

- Safari v. 5+
- Firefox version v.27+
- Internet Explorer v.11+
- Opera® v. 14+